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การพัฒนาโปรแกรม ET-ARM STAMP LPC2119 ดวย GCCARM รวมกับ Editor ของ Keil uVision3  
 
 ในการพัฒนาโปรแกรมของ ARM7 ดวย GCCARM นั้น ตามปรกตแิลว GCCARM จะเปนเพียงโปรแกรม 
C-Complier อยางเดยีว ไมมีสวนของโปรแกรม Text Editor รวมอยูดวย ดังนัน้ในการสราง Source Code จะตอง
ใชโปรแกรมจําพวก Text Editor ตัวอื่นๆในการสราง Source Code ที่เปน Text File แลวบันทึกเปนไฟลภาษาซีไว 
จากนั้นจงึใช GCCARM ในการสั่งแปลคําสั่ง (Complier) อีกครั้งหนึ่ง โดยในการสัง่ Complier นัน้จะเปนการสั่งงาน
แบบ Command Line โดยผูใชจะตองเขาใจรูปแบบคําสั่งและ Option ตางๆในการสั่ง Complier เปนอยางดีจงึจะ
สามารถสัง่ Complier ไดอยางถูกตองตามเงื่อนไขที่ตองการ ซึ่งจะเหน็ไดวาการใชงานโปรแกรม GCCARM นั้นจะ
ไมคอยมีความสะดวกมากนัก เนื่องจากตองสลับการทํางานของโปรแกรมจาก Text Editor ไปยัง Command Line 
เพื่อส่ังแปลโปรแกรม ซึ่งถาเกิดขอผิดพลาดขึ้นก็จะตองกลับเขาไปแกไข Source Code นั้นใหม แลวกลับไปส่ังแปล
โปรแกรมใหมอีก โดยอาจตองวนเวียนอยูเชนนี้หลายๆรอบ จนกวาโปรแกรมที่เขยีนขึ้นนัน้จะเสร็จสมบูรณ แต
อยางไรก็ดี GCCARM ก็มขีอดี ที่ทุกคนปฏิเสธไมได คือ เปนของฟรี ซึ่งสามารถ Download มาใชไดโดยไมเสีย
คาใชจายใดๆ ถึงแมวาจะมีขอจํากัดในเรื่องของความสะดวกสบายในการใชงานอยูบางก็ตาม  
 สําหรับในกรณีที่ผูใชมีชุดโปรแกรม Keil-ARM รุน Demo สําหรับทดลองใชงานอยูแลวนัน้ สามารถ อาศัย
โปแกรม Text Editor ของ Keil-ARM (Keil uVision3) สําหรับเขยีน Source Code ภาษาซี แลวกาํหนดการ
เชื่อมโยง Command Line ใหไปเรียกใชโปรแกรม GCCARM ในการแปลคําสั่งแทนได ซึ่งจะทาํใหผูใชงานสามารถ
ทําการเขียนโปรแกรมภาษาซีและสั่งแปลโปรแกรมไดจากหนาเมนูคําสั่งของโปรแกรม Keil uVision3 ไดเชนเดยีวกัน
การใช Keil-ARM ทุกประการ เพยีงแตวา ขอกําหนดในการเขียนโปรแกรม Source Code ที่เปนภาษาซนีัน้ จะตอง
ยึดหลักการเขยีนโปรแกรมตามรูปแบบและขอกําหนดของ GCCARM แทนเทานัน้ ซึง่ขอดีของการใช GCCARM ก็
คือ ไมมีขอจํากัดในเรื่องขนาดของ Output Hex File เหมือนการใช Keil-ARM รุนทดลองใช(Demo) 
 
ขอแนะนําในการใชงานโปรแกรม 
    - โปรแกรม Keil-ARM รุน Demo สามารถ Download ไดจาก WWW.KEIL.COM โดยในการติดตัง้ใชงาน
นั้น เพื่อใหสะดวกตอการกาํหนดคาตวัเลือกใชงานตางๆขอแนะนําใหติดตั้งโปรแกรมใน Folder ชื่อ C:\keil ตาม
คาตัวเลือกที่เปนคา Default ของโปรแกรมติดตั้งจะดีทีสุ่ด 
  - โปรแกรม GCCARM สามารถ Download ไดจาก WWW.KEIL.COM เชนเดยีวกนั โดยในการติดตั้งใช
งานนัน้ขอแนะนําใหติดตั้งโปรแกรมไวใน Folder ชื่อ C:\Cygnus ตามคาตัวเลือกที่เปนคา Default ของโปรแกรม
ติดตั้งจะดีที่สุด เพราะจะงายในการสั่งกาํหนดคา Option ตางๆในการใชงาน 

เนื่องจากถาตดิตั้งโปรแกรมใน Folder ที่แตกตางไปจากนี้แลว ผูใชตองทาํการปรับแกตําแหนง Folder ใน
ข้ันตอนของการกําหนดคาตัวเลือกในโปรแกรมใหมตามที่ติดตั้งโปรแกรมไวจริงดวยจะไมสามารถอางองิตาม
คําแนะนํานี้ไดทั้งหมด 
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การใช Keil uVision3 รวมกับ GCCARM Complier 
 ในทีน่ี้จะขอแสดงแนวทางการเขียนโปรแกรมภาษาซ ี โดยใช GCCARM ในการแปลคําสั่ง ภายใตโปรแกรม 
Text Editor ของ Keil (Keil uVision3) โดยจะขออธิบายถงึเฉพาะวธิีการกาํหนดคา Option สําหรับเชื่อมโยงคําสั่ง
ในการสัง่แปลโปรแกรมดวย GCCARM ผานทาง Keil uVision3 ของ Keil เทานั้น สวนรายละเอียดคําสั่งและการใช
งานฟงกชัน่ตางๆในการเขียนโปรแกรมของ GCCARM นั้นขอใหผูใชศึกษาจากคูมือคําสั่งของ GCCRAM เอง โดย
วิธีการกําหนดคาตัวเลือกของ Keil uVision3 ใหใชงานกบั GCCARM นั้นมีข้ันตอนพอสังเขปดังนี้คือ 
 
1. เปดโปรแกรม Keil uVision3 ซึ่งเปนโปรแกรม Text Editor ของ Keil-ARM ใชสําหรับใชในการเขียนโปรแกรมที่
เปน Source Code ภาษาซ ีโดยจะมีลักษณะดังรูป 

 

 
 
2. ทาํการกาํหนดคาตัวเลือกในการแปลคําสั่งของ uVision3 ใหใชงานกบัโปรแกรม Keil uVision3 และ GCCARM 
โดยใหเลือกคลิกเมาสที่เมนคํูาสั่ง Project → Components ,Environment, Books… จากนัน้ใหเลือกคาตวัเลือก
สําหรับกาํหนดการใชงาน Complier จากหัวขอ Select ARM Development Tools ซึ่งจะมีคาตัวเลือกอยู 3 แบบ 
คือ Use Keil ARM Tools ,Use GNU Tools และ Use ARM Tools โดยใหเลือกเปน “Use GNU Tools”  จากนั้นให
เลือกกําหนดตําแหนง Folder ที่ไดทําการติดตั้งโปรแกรมไว ซึ่งตามปรกติแลวถาติดตั้งโปรแกรม GCCARM ตามคา 
Default จะอยูที่ C:\Cygnus… ซึ่งจะไดดังรูป (ถาติดตั้งโปรแกรมตางไปจากนี้ใหแกไขตามความเปนจริงดวย) 
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3. ทาํการสราง Project File ข้ึนมาใหม โดยเรียกเมนูคําสั่ง Project → New Project จากนัน้ใหเลือกกาํหนดหรือ
สรางตําแหนง Folder ที่จะบันทกึ Project File พรอมกับกําหนดชื่อ Project File ตามตองการ เชน ถาตองการสราง 
Project File ชื่อ EX1 โดยเก็บไวใน Folder ชื่อ EX1 ก็สามารถกําหนดตําแหนง Folder และชื่อ Project File ไดเอง 
โดยเมื่อกาํหนดชื่อในชอง File name แลวใหเลือก Save เพื่อบันทึก Project File ไว ดังรูป 
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หลังจากกาํหนดชื่อและสั่ง Save Project File แลว โปรแกรมจะรอใหผูใชทาํการกาํหนด เบอร MCU ที่จะ
ใชงานใน Project ที่ส่ัง Save นั้น ซึ่งในกรณีที่ใชงานกับบอรด ET-ARM STAMP LPC2119 นั้น ใหเลือกกาํหนด
เบอรของ MCU เปน LPC2119 ของ Philips แลวเลือก OK ดังรูป 
 

 
 

 ในขั้นตอนนี้โปรแกรมจะรอใหผูใชยืนยันวาตองการจะทาํการ Copy ไฟล Startup เพื่อใชงานกบั MCU ของ 
Philips มาใชใน Project ดวยหรือไม โดย Startup ไฟลจะเปนสวนของการกาํหนดคาเริ่มตนการทาํงานใหกับ MCU 
เชน การกําหนดคา Stack และการกําหนด ค าการทาํงานใหกับ Phase-Lock-Loop ตางๆ กอนที่จะเริ่มตนทาํงาน
ตามโปรแกรมที่เราเขียนขึ้น ไมเชนนั้นแลวโปรแกรมที่เราเขียนขึ้นมานัน้จะตองเพิ่มคําสัง่ในการเตรียมการทาํงาน
สวนเหลานี้ให MCU เองทัง้หมด  

แตเนื่องจากไฟล Startup ของ Keil-ARM นั้น เปนไฟลภาษาแอสแซมบลี้ ซึ่งทั้ง Keil-ARM และ GCCARM 
นั้น จะใชโปรแกรมแอสแซมเบอรตางกนั ดังนัน้ขอกําหนดและรูปแบบไวยากรณทางดานการกําหนดคาบางอยางจะ
มีความแตกตางกนัอยูไมสามารถใชงานไฟล Startup รวมกันได ดังนั้นในการที่จะใชโปรแกรม GCCARM ในการ
แปลคําสั่งใหนั้น ผูใชจะตองสรางไฟล Startup ใหมโดยตองกําหนดรูปแบบใหถูกตองกับที่ GCCARM กําหนดไว 
ดังนัน้ในที่นี้จะตองเลือก “No” เพื่อไมให Keil uVision3 ทําการ Copy ไฟล Startup ของ Keil-ARM มาใชใน 
Project นี้ดวย เนื่องจากรูปแบบของคําสั่งแตกตางกนัและใชงานรวมกนัไมได 
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4. ใหทาํการ Copy File ชื่อ “Flash.ld” และ “Startup.S” ที่ทาง อีททีี จัดเตรียมไวใน CD-ROM ซึ่งเก็บไวใน Folder 
ชื่อ “SOURCE_GCC” มาไวในตําแหนง Folder เดียวกนักับ Project File ที่สรางขึน้มาใหมนี ้ 

โดยไฟล “Flash.ld” จะเปน Script File ซึ่งใชเก็บคาตัวเลือกสาํหรับกําหนดคาตําแหนงเริ่มตนและสิ้นสุด 
รวมทัง้ขนาดของหนวยความจํา Flash และ RAM ที่มอียูจริงภายในตัวของ MCU เบอร LPC2119 ของ Philips ซึ่ง
เปน MCU ที่ใชกับบอรด ET-ARM STAMP LPC2119 โดยคาตางๆทีก่ําหนดไวใน Script File ตัวนี้จะใชเพื่อบอกให
โปรแกรม Keil uVision3 ทราบวาจะตองกําหนดเงื่อนไขการแปลคําสั่งใหกับ GCCARM อยางไรบาง ซึ่งถากาํหนด
เงื่อนไขไมถูกตองแลว HEX File ที่ไดจากการแปลคําสั่งก็จะเกิดความผิดพลาดตามไปดวย  

สวนไฟล “Startup.S” จะเปนไฟลซึง่บรรจุคําสั่งภาษาแอสแซมบลี้ของ ARM7 สําหรับทําหนาที่กําหนดคา
เร่ิมตนการทํางานที่จาํเปนใหกับ MCU ซึ่งไดแกการ กําหนดคา Stack ใหกับ MCU การ Initial Phase-Lock-Loop 
การกําหนดคาใหกับ MAM Function และการกําหนดตําแหนง Vector ตางๆของ MCU 

 
5. ใหทําการกาํหนดคา Option ของ Project File โดยเลือกเมนูคําสั่ง Project → Option for Target ’Target 1’ 
จากนั้นเลือกที ่Tab ของ Target เพื่อกําหนดคาของ MCU Target โดยใหกําหนดดังนี ้

5.1 X-TAL ใหกําหนดเปน 19.6608 MHz 
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5.2 Output ใหเลอืกคลิกเมาสทีค่าตัวเลือก Create HEX File  

 
 

5.3 Linker ใหเลอืกคลิกเมาสทีตั่วเลือก Enable Garbage Collection และ Do not use Standard 
System Startup Files สวน Linker Script File นั้นใหเลอืกกําหนดเปน “Flash.ld” โดยคลิกเมาสที่ปุม
คําสั่ง […] ที่อยูระหวางชองแสดงชื่อ Script File และปุมคําสั่ง “Edit…” จากนั้นก็ใหคลิกเมาสที่ไอคอน
ของไฟล “Flash.ld” แลวเลือก Open ซึ่งจะปรากฏชื่อของ Script File ดังกลาวในชองแสดงชือ่ของ 
Script File ทนัท ี

 
 

กําหนด 
Script 
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↓ 
 

 
 

 หลังการทาํการกําหนด Script File ใหกับ Project เปนทีเ่รียบรอยแลว ในขั้นตอนถัดไปใหทาํการกําหนดคา
ตําแหนงแอดเดรสเริ่มตนของหนวยความจําที่จะใชในการเก็บโปรแกรมและขอมูล โดยในกรณีของ LPC2119 ใหทาํ
การกําหนดคาเปนดังนี ้

- Text Start ใหกําหนดเปน 0x0000 0000 
- Data Start ใหกําหนดเปน 0x4000 0000 

 
ซึ่งจะสงัเกตเหน็วาโปรแกรม Keil uVision3 จะแสดง Option ในการแปลคําสั่งใหเราทราบดวยทางชอง

แสดงคาของ Linker Control String โดยคาจะเปลี่ยนแปลงไปตามการกําหนดเงื่อนไขของเราดังรูป 
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6. เร่ิมตนเขียน Source Code ภาษาซ ีโดยใหเลือกคลิกเมาสทีเ่มนูคําสั่ง File → New… ซึ่งจะไดพื้นที่ในการเขยีน 
Text File เกิดขึ้นมา โดยในครั้งแรกจะกําหนดชื่อตามคา Default เปน “Text1” ดังรูป 
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 ในขั้นตอนนี้ใหทาํการพิมพ Source Code ภาษาซ ีตามขอกําหนดของ GCCARM ในพืน้ที่เขียนโปรแกรม
ตามตองตองการดังตัวอยาง 
 
/*****************************************************/ 
/* Examples Program For "ET-ARM STAMP LPC2119" Board */ 
/* Target MCU  : Philips ARM7-LPC2119                */ 
/*           : X-TAL : 19.6608 MHz                   */ 
/*             : Run Speed 58.9824MHz (With PLL)     */ 
/* Compiler    : GCC ARM V3.31                 */ 
/* Last Update : 1/September/2005                    */ 
/* Function    : Example Use GPIO-1on Output Mode    */ 
/*             : LED Blink on GPIO1.16               */ 
/*****************************************************/ 
 
#include <LPC21xx.H>            // LPC2119 MPU Register 
 
/* pototype  section */ 
void delay_led(unsigned long int); // Delay Time Function 
 
int main(void) 
{   
  PINSEL2 &= 0xFFFFFFFC;   // Set GPIO1.16 = GPIO Function 
  IODIR1   = 0x00010000;   // Set GPIO1.16 = Output 
  IOSET1   = 0x00010000;           // Set GPIO1.16 Pin (OFF LED) 
 
  // Loop Blink LED on GPIO1.16 // 
  while(1)     // Loop Continue 
  { 
     IOCLR1 = 0x00010000;  // Clear Pin P1.16 (ON LED) 
 delay_led(1500000);      // Display LED Delay 
 IOSET1 = 0x00010000;          // Set Pin P1.16 (OFF LED)      
 delay_led(1500000);   // Display LED Delay 
  }    
}    
 
/***********************/ 
/* Delay Time Function */ 
/*    1-4294967296     */ 
/***********************/ 
void delay_led(unsigned long int count1) 
{ 
  while(count1 > 0) {count1--;} // Loop Decrease Counter  
} 
 

ตัวอยางโปรแกรมไฟกระพริบ 1 ดวง ที่ GPIO1.16 
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 หลังจากพิมพคําสั่งภาษาซีเสร็จเรียบรอยตามตองการแลว ใหส่ัง Save ไฟลดังกลาว โดยตองกาํหนดเปน
ไฟลที่มนีามสกุลเปน “.C” ในทีน่ี้ขอแนะนําใหส่ัง Save โดยใชคําสัง่ File → Save As… แลวกําหนดชือ่และ
นามสกุลของไฟลเปน .main.c” ดังรูป 
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 ซึ่งหลงัจากที่ส่ัง Save ไฟลเปน “main.c” แลวจะเหน็วาลักษณะสีของตัวอักขระตางๆในโปรแกรมจะเกิด
การเปลี่ยนแปลงไปตามหนาที่ เชน  Comment, ตัวแปร และ คําสั่ง เปนตน ซึง่สวนนี้เปนขอดีของ Keil uVision3 ซึ่ง
สามารถแยกและแสดงตัวอักขระไดอยางเปนหมวดหมู ทาํใหงายตอการอานโปรแกรมดวย ดังรูป 
 

 
 
7. ทําการสัง่ Add File ตางๆเขากับ Project File โดยใหเลือกคลิกเมาสที่คําสั่ง Project → Components, 
Environment, Books… จากนัน้ใหเลือกที ่Tab Project Components แลวเลือกที่ Add File ที่ตองการจะเพิ่มเขา
ไปใชงานรวมกับ Project File 

โดยในครั้งแรกใหเลือก Files of type เปน “C Source files(*.c)” ซึง่จะปรากฏชื่อไฟลตางๆทีเ่ปน Source 
Code ภาษาซใีหเหน็ โดยในที่นี้ใหเลือกคลกิเมาสที่ไอคอนของไฟลชื่อ “main.c” แลวเลือก Add เพื่อส่ังเพิ่มไฟลชื่อ 
“Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 
 จากนั้นใหเลือกกําหนด File of type ใหมเปน “ASM Source files(*.s*;*.src;*.a*) ซึ่งจะปรากฏชื่อของไฟล 
Startup.s ใหเห็นในชองแสดงชื่อไฟล ใหทําการคลิกเมาสที่ไอคอนของไฟล “Startup.s” แลวเลือก Add เพื่อส่ังเพิ่ม
ไฟลชื่อ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว  
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 เมื่อทําการสัง่ Add ไฟลชื่อ “main.c’ และ “Startup.s” ใหกับ Project File เปนทีเ่รียบรอยแลวใหเลือกที่ 
Close เพื่อเปนการสิน้สุดการสั่ง Add File ซึ่งจะไดดังรูป 

 
 
↓ 
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↓ 
 

 
 
 ซึ่งหลงัจากทาํการสั่ง Add File ทั้ง “main.c” และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลว จะ
สังเกตเห็นที่ชอง Tab ของ File ปรากฏชื่อของ File ทั้ง 2 ใหเห็นดวย 
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8. ใหทําการสัง่แปลโปรแกรมที่เราเขียนขึน้เรียบรอยแลว โดยใหคลิกเมาสที่เมนูคําสั่ง Projects → Rebuild all 
target files ซึ่งโปรแกรม Keil uVision3 จะทําการสั่งใหโปรแกรม GCCARM ทําการแปลคําสั่งใหทันท ี

 

 
 

 ซึ่งหลงัจากสั่งแปลโปรแกรมแลวไดผลถูกตองและไมเกิดขอผิดพลาดใดๆขึ้น (0 Error และ 0 Warning) ก็
ได Hex File ซึ่งมีชื่อเหมือนกันกับชื่อของ Project File ที่สรางไว ซึง่ผูใชสามารถนาํ Hex File ดังกลาวไปทําการ 
Download ใหกับ MCU ไดทันท ี
 
ขอแนะนําในการ Initial MCU กอนเริ่มตนการทาํงานของโปรแกรมหลกั 
 เพื่อใหการทาํงานของ MCU มีประสิทธิภาพสงูสุด ทัง้ในดานของความเร็วในการประมวลผลคําสัง่ และการ
ทํางานควรกาํหนดคาตางๆใหกับ MCU ดังตอไปนี ้

- ควรกําหนดคา PLL ใหไดคา Processor Clock (cclk) = 58.9824MHz โดยในกรณีที่ใชคา XTAL เปน 
19.6608MHz ตองใหคา M(Multiply)=3 และ P(Divide)=2 และ FFCO =235.9296MHz 

- ควรกําหนดคา VPB Clock (pclk) ใหมีคา เปนครึ่งหนึ่งของ cclk หรือ 29.4912MHz 
- ควรกําหนดคา MAM Timing ใหมีคา 3 Cycle ของ cclk (MAMTIM = 0x03) 
- ควรกําหนดคา MAM Mode เปน Full Enable (MAMCR = 0x02) 
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โดยการกาํหนดคาตางๆดังกลาวขางตนนัน้ สามารถทาํได 2 วิธีคือ การเขียน Code คําสั่งในโปรแกรมที่เรา
เขียนขึ้นเองทัง้หมด หรือใชการ Copy ไฟลที่เปน Startup File และ Script File ที่สรางไวเรียบรอยแลวมาใชงาน 
จากนั้นจงึสั่ง Add Startup File และ Script File เขามาใชงานใน Project ที่เราสรางขึ้น ซึ่งการตรวจสอบและแกไข
คาของ Startup File และ Script File นั้น สามารถทําได 2 แบบ คือ เขาไปแกไข Code คําสั่งในไฟลตามความ
ตองการ หรือ ใชการกําหนดคา Startup File และ Script File จากหนาตางโปรแกรมของ Keil uVision3 เอง ซึง่
เพื่อใหเกิดความสะดวกตอการใชงานขอแนะนาํใหใชวธิีการแกไขเปลี่ยนแปลงคาจาก Keil uVision3 จะดีที่สุด  
 
การตรวจสอบคา Startup File 

 หนาที่ของ Startup File คือ บรรจุคําสั่งของโปรแกรมเริ่มตนการทํางานของ MCU กอนทีจ่ะเริ่มตนมา
ทํางานตามคาํสั่งที่เราเขียนขึน้ โดยโปรแกรมที่อยูใน Startup ไฟลจะทาํหนาที ่ Initial การทาํงานของ MCU ในสวน
ที่จําเปนกอน จากนั้นจงึจะกระโดดไปทํางานตามคําสั่งในโปรแกรมภาษาซทีี่เราเขียนขึ้น ซึง่การเขาไปตรวจสอบคา
ของ Startup ไฟลสามารถทาํไดโดย ใหเลอืกคลิกที ่Tab ของไฟล Startup แลวเลือก “Expand All” ซึ่งจะเหน็คาที่
กําหนดไวใน Startup File ดังรูป 
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แสดงการกําหนดคา Startup File สําหรับ LPC2119 
 

การตรวจสอบ Script File 
 สําหรับหนาทีข่อง Script File นัน้จะใชเกบ็คาที่กาํหนดตําแหนงและขนาดของหนวยความจําใน MCU หรือ 
Target บอรดที่จะใชกับโปรแกรมที่เราเขียนขึ้น โดยในกรณีที่ใช LPC2119 นัน้ จะมขีนาดของหนวยความจํา Code 
Flash ขนาด 128K โดยมีตําแหนงเริ่มตนอยูที ่ 00000000H-0001FFFFH สวนหนวยความจาํ Data RAM จะมี
ขนาด 16KByte โดยมีตําแหนงอยูที่ 40000000H-40003FFFH ซึ่งใน Script File ชื่อ “Flash.ld” ที่จัดทาํไวใน
ตัวอยางภาษาซี ของ GCCARM โดยอีททีี นัน้จะกําหนดคา Configuration ของหนวยความจําไวอยางถกูตอง
สําหรับ LPC2119 อยูแลว แตถามีการเขาไปแกไขหรือเปลี่ยนแปลงคาเปนอยางอื่นอาจทาํใหโปรแกรมที่ไดจากการ
แปลคําสั่งของ GCCARM ไมสามารถทาํงานไดอยางถกูตอง โดยการตรวจสอบคาความถกูตองของ Configuration 
ใน Script File สามารถทําไดโดยการสั่ง Open ไฟล ชือ่ “Flash.ld” ซึ่งอยูใน Folder เดียวกันกบั Project File ดวย
โปรแกรม Keil uVision3 หรือถามกีารสัง่ Open File ไวอยูแลวใหเลือก Tab ของไฟลไปยัง “Flash.ld” แลว
เลือก”Expand All” จากนัน้ใหตรวจสอบคาตางๆดูวาเปนไปตามที่กําหนดไวหรือไม ซึ่งคาที่ถกูตองจะตองเปนดงัรูป 
 

 
 

แสดงการกําหนดคา Script File สําหรบั LPC2119 
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ตัวอยาง Code ภาษาซีของ GCCARM สําหรบั Initial การทํางานของ LPC2119 
 สําหรับในกรณีที่ตองการเขียนโปรแกรม Initial การทํางานของ MCU เอง ก็สามารถทาํได โดยการเพิ่ม 
Code คําสั่งเขาไปในสวนเริ่มตนการทํางานของ Main Program ดังตัวอยาง 
 

// Initial PLL & VPB Clock For ET-ARM7 STAMP LPC2119 
// Start of Initial PLL for Generate Processor Clock  
// PLL Configuration Setup 
// X-TAL = 19.6608MHz   
// M(Multiply) = 3 
// P(Divide) = 2 
// Processor Clock(cclk) = M x OSC  
//                       = 3 x 19.6608MHz  
//                       = 58.9824MHz 
// FCCO = cclk x 2 x P 
//      = 58.9824 x 2 x P 
//      = 235.9296 MHz 
// VPB Clock(pclk) = 29.4912MHz 
// Start of Initial PLL for Generate Processor Clock  
PLLCFG &= 0xE0;    // Reset MSEL0:4 
PLLCFG |= 0x02;    // MSEL(PLL Multiply) = 3 
PLLCFG &= 0x9F;    // Reset PSEL0:1 
PLLCFG |= 0x20;    // PSEL(PLL Devide) = 2 
 
PLLCON &= 0xFC;    // Reset PLLC,PLLE 
PLLCON |= 0x01;    // PLLE = 1 = Enable PLL 
  
PLLFEED = 0xAA;    // Start Update PLL Config 
PLLFEED = 0x55; 
while (!(PLLSTAT & 0x00000400));  // Wait PLL Lock bit 
  
PLLCON |= 0x02;    // PLLC = 1 (Connect PLL Clock) 
PLLFEED = 0xAA;     // Start Update PLL Config 
PLLFEED = 0x55; 
 
VPBDIV &= 0xFC;    // Reset VPBDIV 
VPBDIV |= 0x02;    // VPB Clock(pclk) = cclk / 2 
// End of Initial PLL for Generate Processor Clock  
   
// Start of Initial MAM Function 
MAMCR = 0x00;     // Disable MAM Function 
MAMTIM = 0x03;     // MAM Timing = 3 Cycle of cclk 
MAMCR = 0x02;     // Enable MAM = Full Function 
// End of Initial MAM Function 
 
// Start of Main Function Here 
. 

 
แสดงตัวอยาง Code สําหรับ Initial การทํางานของ LPC2119 กอนเริ่มตนทํางานใน Main โปรแกรม 


