
ตัวอยางการพัฒนาโปรแกรมของบอรด ET-JR ARM7 LPC2214 ดวย Keil-CARM   

ETT CO., LTD. -1- WWW.ETT.CO.TH 
 

ตัวอยางการใช Keil uVision3 ในการสราง Project File ของ Keil ARM 
  

ในที่นี้จะขอแสดงแนวทางการเขียนโปรแกรมภาษาซี โดยใช Keil-CARM ในการแปลคําสั่ง ภายใต
โปรแกรม Text Editor ของ Keil (Keil uVision3) โดยจะขออธิบายถึงเฉพาะวิธีการกําหนดคา Option สําหรับ
เชื่อมโยงคําสั่งในการสั่งแปลโปรแกรมดวย Keil-CARM ผานทาง Keil uVision3 เทานั้น สวนรายละเอียดคําสั่ง
และการใชงานฟงกช่ันตางๆในการเขียนโปรแกรมของ Keil-CARM นั้นขอใหผูใชศึกษาจากคูมือคําสั่งของ 
Keil-CARM เอง โดยวิธีการกําหนดคาตัวเลือกของ Keil uVision3 ใหใชงานกับ Keil-CARM นั้นมีขั้นตอนพอ
สังเขปดังนี้คือ 
1. เปดโปรแกรม Keil uVision3 ซ่ึงเปนโปรแกรม Text Editor ของ Keil-CARM ใชสําหรับใชในการเขียน

โปรแกรมที่เปน Source Code ภาษาซี โดยจะมีลักษณะดงัรูป 
 

 
 

2. ทําการกําหนดคาตัวเลือกในการแปลคําสั่งของ uVision3 ใหใชงานกับโปรแกรม Keil uVision3 และ Keil-
CARM โดยใหเลือกคลิกเมาสที่เมนูคําสั่ง Project → Components ,Environment, Books… จากนั้นใหเลือก
คาตัวเลือกสําหรับกําหนดการใชงาน Complier จากหวัขอ Select ARM Development Tools ซ่ึงจะมีคา
ตัวเลือกอยู 3 แบบ คือ Use Keil-CARM Tools ,Use GNU Tools และ Use ARM Tools โดยใหเลือกเปน 
“Use Keil ARM Tools”  จากนั้นใหทําการกําหนดตําแหนง Folder สําหรับเก็บคาตัวเลือกการทํางานของ
โปรแกรม Keil ARM ซ่ึงตามปรกติแลวจะเปน “C:\Keil\ARM\” แตถาติดตั้ง Keil ไวที่อ่ืนก็ตองปรับเปลี่ยน
ใหถูกตองตามความเปนจริงดวยดังรูป 
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3. ทําการสราง Project File ขึ้นมาใหม โดยเรียกเมนูคําสั่ง Project → New Project จากนั้นใหเลือกกําหนด

หรือสรางตําแหนง Folder ที่จะบันทกึ Project File พรอมกับกําหนดชื่อ Project File ตามตองการ เชน ถา
ตองการสราง Project File ช่ือ DEMO1 โดยเก็บไวใน Folder ช่ือ DEMO1 ก็สามารถกําหนดตําแหนง Folder 
และชื่อ Project File ไดเอง โดยเมื่อกําหนดชื่อในชอง File name แลวใหเลือก Save เพื่อบันทึก Project File 
ไว ดังรูป 
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หลังจากกําหนดชื่อและสั่ง Save Project File แลว โปรแกรมจะรอใหผูใชทําการกําหนด เบอร MCU ที่
จะใชงานใน Project ที่ส่ัง Save นั้น ซ่ึงในกรณีที่ใชงานกับบอรด ET-ARM7 LPC2114 นั้น ใหเลือกกําหนดเปน 
MCU ของ Philips เบอร LPC2114 แลวเลือก OK ดังรูป 

 

 
 

 หลังจากเลือกกําหนดเบอรของ MCU เปนที่เรียบรอยแลว ในขั้นตอนนี้โปรแกรมจะรอใหผูใชยนืยันวา
ตองการจะทําการ Copy ไฟล Startup ของ Keil เพื่อใชงานกับ MCU ของ Philips มาใชใน Project ดวยหรือไม 
โดย Startup ไฟลจะเปนสวนของการกําหนดคาเริ่มตนการทํางานใหกบั MCU เชน การกําหนดคา Stack และ
การกําหนดค าการทํางานใหกับ Phase-Lock-Loop ตางๆ กอนที่จะเริ่มตนทํางานตามโปรแกรมที่เราเขียนขึ้น 
ไมเชนนัน้แลวโปรแกรมที่เราเขียนขึ้นมานั้นจะตองเพิ่มคําสั่งในการเตรียมการทํางานสวนเหลานี้ให MCU เอง
ทั้งหมด  

แตเนื่องจากไฟล Startup ของ Keil-ARM นั้น เปนไฟลภาษาแอสแซมบลี้ ซ่ึงกําหนดคาการทํางานไวกับ
ชุดพัฒนาของ Keil เอง ดังนั้นขอกําหนดและการกําหนดคาบางอยางจะมีความแตกตางกันอยูกบัคาที่ตองการ
สําหรับ บอรด “ET-ARM7 LPC2114” ไมสามารถใชงานไฟล Startup ไดทันที ตองมีการแกไขคาตัวเลือกใหม 
ดังนั้นกอนที่จะใชโปรแกรม Keil-CARM ในการแปลคําสั่งใหนั้น ผูใชจะตองเขาไปแกไขไฟล Startup ใหมโดย
ตองกําหนดรูปแบบใหถูกตองตรงกับความตองการของบอรด “ET-ARM7 LPC2114” ดวย ดังนั้นในที่นี้ขอ
แนะนําใหเลือก “No” เพื่อไมให Keil uVision3 ทําการ Copy ไฟล Startup ของ Keil-CARM มาใชใน Project นี้
ดวย  
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4. ใหทําการ Copy File ช่ือ “Startup.s” ที่ทาง อีทีที จัดเตรียมไวใน CD-ROM ซ่ึงเก็บไวใน Example ช่ือ 
“Startup.s” มาไวในตําแหนง Folder เดียวกันกับ Project File ที่สรางขึ้นมาใหมนี้  

โดยไฟล “Startup.s” จะเปนไฟลซ่ึงบรรจุคําสั่งภาษาแอสแซมบลี้ของ ARM7 สําหรับทําหนาที่
กําหนดคาเริ่มตนการทํางานที่จําเปนใหกับ MCU ซ่ึงไดแกการ กําหนดคา Stack ใหกับ MCU การ Initial 
Phase-Lock-Loop การกําหนดคาใหกับ MAM Function และการกําหนดตําแหนง Vector ตางๆของ MCU 
สําหรับใชงานรวมกับบอรด “ET-ARM7 LPC2114” ซ่ึงถาสั่ง Add ไฟล “Startup.s” จาก Keil หรือ Copy 
ไฟลดังกลาวมาจากแหลงอื่นๆ อาจมีการทํางานของโปรแกรมใน Startup ไมเหมือนกัน ซ่ึงจะสงผลตอการ
ทํางานของโปรแกรมที่จะเขียนขึ้นดวย 

 
5.  ใหทําการกําหนดคา Option ของ Project File โดยเลือกเมนูคําสั่ง Project → Option for Target ’Target 1’ 
จากนั้นเลือกที ่Tab ของ Target เพื่อกําหนดคาของ MCU Target โดยใหกําหนดดังนี้ 

5.1 X-TAL ใหกําหนดเปน 19.6608 MHz พรอมกับเลือกกาํหนดใหใชหนวยความจําทีม่ีอยูใน MCU 
เปนเงื่อนไขในการแปลโปรแกรมของ Keil-CARM ดวย ดังรูป 
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5.2 Output ใหเลือกคลิกเมาสที่คาตัวเลือก Create HEX File พรอมกับเลือกกาํหนดรูปแบบของ Hex ให
เปนแบบ HEX-386 แลวเลือก OK ดังรูป 

 

 
 

6. เร่ิมตนเขียน Source Code ภาษาซี โดยใหเลือกคลิกเมาสที่เมนูคําสั่ง File → New… ซ่ึงจะไดพืน้ที่ในการ
เขียน Text File เกิดขึ้นมา โดยในครั้งแรกจะกําหนดชื่อตามคา Default เปน “Text1” ดังรูป 
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 ในขั้นตอนนี้ใหทําการพิมพ Source Code ภาษาซี ตามขอกําหนดของ Keil-CARM ในพื้นที่เขยีน
โปรแกรมตามตองตองการดงัตัวอยาง 
 
/******************************************************/ 
/* Examples Program For "ET-JR ARM7 LPC2214" Board       */ 
/* Target MCU  : Philips ARM7TDMI-S LPC2214           */ 
/*             : X-TAL: 19.6608 MHz                   */ 
/*              : Run Speed 58.9824MHz (With PLL)      */ 
/* Compiler    : Keil ARM V2.32a           */ 
/* Last Update : 15/05/2006                   */ 
/* Function     : Example Use GPIO-1 on Output Mode  */ 
/*              : LED Blink on GPIO1.16                */  
/******************************************************/ 
 
#include <LPC22xx.H>                 // LPC2214 MPU Register 
 
/* prototype section */ 
void delay_led(unsigned long int);   // Delay Time Function 
 
int main(void) 
{   
  PINSEL2 &= 0xFFFFFFFC;       // Makesure GPIO1.16 = GPIO 
Function 
  IODIR1   = 0x00010000;        // Set GPIO1.16 = Output 
  IOSET1   = 0x00010000;          // Set GPIO1.16 Output Pin (OFF 
LED) 
 
  // Loop Blink LED on GPIO1.16 // 
  while(1)           
  // Loop Continue 
  { 
    IOCLR1 = 0x00010000;      // Clear Output Pin P1.16 (ON LED) 
 delay_led(1500000);           
  // Display LED Delay 
 IOSET1 = 0x00010000;           // Set Output Pin P1.16 (OFF LED)
      
 delay_led(1500000);        
  // Display LED Delay 
  }    
}    
 
/***********************/ 
/* Delay Time Function */ 
/*    1-4294967296     */ 
/***********************/ 
void delay_led(unsigned long int count1) 
{ 
  while(count1 > 0) {count1--;}    // Loop Decrease Counter  
} 

 

ตัวอยางโปรแกรมไฟกระพริบ 1 ดวง ท่ี GPIO1.16 
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 หลังจากพิมพคําสั่งภาษาซีเสร็จเรียบรอยตามตองการแลว ใหส่ัง Save ไฟลดังกลาว โดยตองกาํหนด
เปนไฟลที่มีนามสกุลเปน “.C” ในที่นี้ขอแนะนําใหส่ัง Save โดยใชคําสั่ง File → Save As… แลวกําหนดชื่อ
และนามสกุลของไฟลเปน “main.c” ดังรูป 
 

  
 
 ซ่ึงหลังจากทีส่ั่ง Save ไฟลเปน “main.c” แลวจะเหน็วาลักษณะสีของตัวอักขระตางๆในโปรแกรมจะ
เกิดการเปลีย่นแปลงไปตามหนาที่ เชน Comment, ตัวแปร และ คาํสั่ง เปนตน ซ่ึงสวนนี้เปนขอดีของ Keil 
uVision3 ซ่ึงสามารถแยกและแสดงตวัอักขระไดอยางเปนหมวดหมู ทาํใหงายตอการอานโปรแกรมดวย ดังรูป 
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7. ทําการสั่ง Add File ตางๆเขากับ Project File โดยใหเลือกคลิกเมาสที่คําสั่ง Project → Components, 

Environment, Books… จากนั้นใหเลือกที่ Tab Project Components แลวเลือกที่ Add File ที่ตองการจะเพิ่ม
เขาไปใชงานรวมกับ Project File 

โดยในครั้งแรกใหเลือก Files of type เปน “C Source files(*.c)” ซ่ึงจะปรากฏชื่อไฟลตางๆที่เปน 
Source Code ภาษาซีใหเหน็ โดยในที่นีใ้หเลือกคลิกเมาสที่ไอคอนของไฟลช่ือ “main.c” แลวเลือก Add เพื่อ
ส่ังเพิ่มไฟลช่ือ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 

จากนั้นใหเลือกกําหนด File of type ใหมเปน “ASM Source files(*.s*;*.src;*.a*) ซ่ึงจะปรากฏชื่อ
ของไฟล Startup.s ใหเห็นในชองแสดงชือ่ไฟล ใหทําการคลิกเมาสที่ไอคอนของไฟล “Startup.s” แลวเลือก 
Add เพื่อส่ังเพิ่มไฟลช่ือ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 

เมื่อทําการสั่ง Add ไฟลช่ือ “main.c’ และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลวให
เลือกที่ Close เพื่อเปนการสิน้สุดการสั่ง Add File ซ่ึงจะไดดังรูป 
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↓ 
 

 
 

ซ่ึงหลังจากทําการสั่ง Add File ทั้ง “main.c” และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลว จะ
สังเกตเห็นที่ชอง Tab ของ File ปรากฏชื่อของ File ทั้ง 2 ใหเห็นดวย 
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8. ใหทําการสั่งแปลโปรแกรมที่เราเขียนขึ้นเรียบรอยแลว โดยใหคลิกเมาสที่เมนูคําสั่ง Projects → 
Rebuild all target files ซ่ึงโปรแกรม Keil uVision3 จะทําการสั่งใหโปรแกรม Keil-CARM ทําการแปล
คําสั่งใหทันท ี

 

 
 

ซ่ึงหลังจากสั่งแปลโปรแกรมแลวไดผลถูกตองและไมเกิดขอผิดพลาดใดๆขึ้น (0 Error และ 0 
Warning) ก็ได Hex File ซ่ึงมีช่ือเหมือนกนักับชื่อของ Project File ที่สรางไว ซ่ึงผูใชสามารถนํา Hex 
File ดังกลาวไปทําการ Download ใหกับ MCU ไดทันท ี

 
ขอแนะนําในการ Initial MCU กอนเริ่มตนการทํางานของโปรแกรมหลัก 
 เพื่อใหการทํางานของ MCU มีประสิทธิภาพสูงสุด ทั้งในดานของความเร็วในการประมวลผลคําสั่ง 
และการทํางานควรกําหนดคาตางๆใหกับ MCU ดังตอไปนี้ 

- ควรกําหนดคา PLL ใหไดคา Processor Clock (cclk) = 58.9824MHz โดยในกรณีทีใ่ชคา XTAL เปน 
19.6608MHz ตองใหคา M(Multiply)=3 และ P(Divide)=2 และ FFCO =235.9296MHz 

- ควรกําหนดคา VPB Clock (pclk) ใหมีคา เปนครึ่งหนึ่งของ cclk หรือ 29.4912MHz 
- ควรกําหนดคา MAM Timing ใหมีคา 3 Cycle ของ cclk (MAMTIM = 0x03) 
- ควรกําหนดคา MAM Mode เปน Full Enable (MAMCR = 0x02) 
โดยการกําหนดคาตางๆดังกลาวขางตนนั้น สามารถทําได 2 วิธีคือ การเขียน Code คําสั่งในโปรแกรมที่เรา

เขียนขึ้นเองทัง้หมด หรือใชการ Copy ไฟลที่เปน Startup File ที่สรางไวเรียบรอยแลวมาใชงาน จากนั้นจึงสั่ง 
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Add Startup File เขามาใชงานใน Project ที่เราสรางขึ้น ซ่ึงการตรวจสอบและแกไขคาของ Startup File นั้น 
สามารถทําได 2 แบบ คือ เขาไปแกไข Code คําสั่งในไฟลตามความตองการ หรือ ใชการกําหนดคา Startup File 
จากหนาตางโปรแกรมของ Keil uVision3 เอง ซ่ึงเพื่อใหเกดิความสะดวกตอการใชงานขอแนะนําใหใชวิธีการ
แกไขเปลี่ยนแปลงคาจาก Keil uVision3 จะดีที่สุด  
 
การตรวจสอบคา Startup File 

 หนาที่ของ Startup File คือ บรรจุคําสั่งของโปรแกรมเริ่มตนการทํางานของ MCU กอนที่จะเริ่มตนมา
ทํางานตามคําสั่งที่เราเขียนขึน้ โดยโปรแกรมที่อยูใน Startup ไฟลจะทาํหนาที่ Initial การทํางานของ MCU ใน
สวนที่จําเปนกอน จากนั้นจึงจะกระโดดไปทํางานตามคําสั่งในโปรแกรมภาษาซีที่เราเขียนขึ้น ซ่ึงการเขาไป
ตรวจสอบคาของ Startup ไฟลสามารถทําไดโดย ใหเลือกคลิกที่ Tab ของไฟล Startup แลวเลือก “Expand All” 
ซ่ึงจะเหน็คาที่กําหนดไวใน Startup File ดงัรูป 
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แสดงการกําหนดคา Startup File สําหรับ LPC2214 
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ตัวอยาง Code ภาษาซีของ Keil-CARM สําหรับ Initial การทํางานของ LPC2214 
 

 สําหรับในกรณีที่ตองการเขยีนโปรแกรม Initial การทํางานของ MCU เอง ก็สามารถทําได โดยการเพิ่ม 
Code คําสั่งเขาไปในสวนเริม่ตนการทํางานของ Main Program ดังตัวอยาง 
 

// Initial PLL & VPB Clock For ET-JR ARM7 LPC2214 
// Start of Initial PLL for Generate Processor Clock  
// PLL Configuration Setup 
// X-TAL = 19.6608MHz   
// M(Multiply) = 3 
// P(Divide) = 2 
// Processor Clock(cclk) = M x OSC  
//                       = 3 x 19.6608MHz  
//                       = 58.9824MHz 
// FCCO = cclk x 2 x P 
//      = 58.9824 x 2 x P 
//      = 235.9296 MHz 
// VPB Clock(pclk) = 29.4912MHz 
// Start of Initial PLL for Generate Processor Clock  
PLLCFG &= 0xE0;     // Reset MSEL0:4 
PLLCFG |= 0x02;     // MSEL(PLL Multiply) = 3 
PLLCFG &= 0x9F;     // Reset PSEL0:1 
PLLCFG |= 0x20;     // PSEL(PLL Devide) = 2 
 
PLLCON &= 0xFC;     // Reset PLLC,PLLE 
PLLCON |= 0x01;     // PLLE = 1 = Enable PLL 
  
PLLFEED = 0xAA;     // Start Update PLL Config 
PLLFEED = 0x55; 
while (!(PLLSTAT & 0x00000400));  // Wait PLL Lock bit 
  
PLLCON |= 0x02;     // PLLC = 1 (Connect PLL Clock) 
PLLFEED = 0xAA;      // Start Update PLL Config 
PLLFEED = 0x55; 
 
VPBDIV &= 0xFC;     // Reset VPBDIV 
VPBDIV |= 0x02;     // VPB Clock(pclk) = cclk / 2 
// End of Initial PLL for Generate Processor Clock  
   
// Start of Initial MAM Function 
MAMCR = 0x00;     // Disable MAM Function 
MAMTIM = 0x03;     // MAM Timing = 3 Cycle of cclk 
MAMCR = 0x02;     // Enable MAM = Full Function 
// End of Initial MAM Function 
 
// Start of Main Function Here 
. 

 

แสดงตัวอยาง Code สําหรับ Initial การทํางานของ LPC2214 กอนเริ่มตนทํางานใน Main โปรแกรม 



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.3
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveEPSInfo true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 2400
  /ColorImageDepth -1
  /ColorImageDownsampleThreshold 10.00000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 2400
  /GrayImageDepth -1
  /GrayImageDownsampleThreshold 10.00000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages true
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 2400
  /MonoImageDepth 8
  /MonoImageDownsampleThreshold 10.00000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile (None)
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /Description <<
    /FRA <>
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308000200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e30593002537052376642306e753b8cea3092670059279650306b4fdd306430533068304c3067304d307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e30593002>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
    /KOR <FEFFd5a5c0c1b41c0020c778c1c40020d488c9c8c7440020c5bbae300020c704d5740020ace0d574c0c1b3c4c7580020c774bbf8c9c0b97c0020c0acc6a9d558c5ec00200050004400460020bb38c11cb97c0020b9ccb4e4b824ba740020c7740020c124c815c7440020c0acc6a9d558c2edc2dcc624002e0020c7740020c124c815c7440020c0acc6a9d558c5ec0020b9ccb4e000200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /CHS <FEFF4f7f75288fd94e9b8bbe7f6e521b5efa76840020005000440046002065876863ff0c5c065305542b66f49ad8768456fe50cf52068fa87387ff0c4ee563d09ad8625353708d2891cf30028be5002000500044004600206587686353ef4ee54f7f752800200020004100630072006f00620061007400204e0e002000520065006100640065007200200035002e00300020548c66f49ad87248672c62535f003002>
    /CHT <FEFF4f7f752890194e9b8a2d5b9a5efa7acb76840020005000440046002065874ef65305542b8f039ad876845f7150cf89e367905ea6ff0c4fbf65bc63d066075217537054c18cea3002005000440046002065874ef653ef4ee54f7f75280020004100630072006f0062006100740020548c002000520065006100640065007200200035002e0030002053ca66f465b07248672c4f86958b555f3002>
    /ENU <>
  >>
>> setdistillerparams
<<
  /HWResolution [4000 4000]
  /PageSize [612.000 792.000]
>> setpagedevice


