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ตัวอยางการใช Keil uVision3 ในการสราง Project File ของ Keil ARM 
 ในทีน่ี้จะขอแสดงแนวทางการเขียนโปรแกรมภาษาซี โดยใช Keil-CARM ในการแปลคําสั่ง ภายใต
โปรแกรม Text Editor ของ Keil (Keil uVision3) โดยจะขออธิบายถงึเฉพาะวธิีการกาํหนดคา Option สําหรับ
เชื่อมโยงคําสัง่ในการสั่งแปลโปรแกรมดวย Keil-CARM ผานทาง Keil uVision3 เทานัน้ สวนรายละเอียดคําสั่งและ
การใชงานฟงกชั่นตางๆในการเขียนโปรแกรมของ Keil-CARM นั้นขอใหผูใชศึกษาจากคูมือคําสัง่ของ Keil-CARM 
เอง โดยวิธกีารกําหนดคาตวัเลือกของ Keil uVision3 ใหใชงานกับ Keil-CARM นัน้มีข้ันตอนพอสังเขปดังนี้คือ 
 
1. เปดโปรแกรม Keil uVision3 ซึ่งเปนโปรแกรม Text Editor ของ Keil-CARM ใชสําหรับใชในการเขียนโปรแกรมที่
เปน Source Code ภาษาซ ีโดยจะมีลักษณะดังรูป 

 

 
 
2. ทําการกําหนดคาตัวเลือกในการแปลคําสั่งของ uVision3 ใหใชงานกบัโปรแกรม Keil uVision3 และ Keil-CARM 
โดยใหเลือกคลิกเมาสที่เมนคํูาสั่ง Project → Components ,Environment, Books… จากนัน้ใหเลือกคาตวัเลือก
สําหรับกาํหนดการใชงาน Complier จากหัวขอ Select ARM Development Tools ซึ่งจะมีคาตัวเลือกอยู 3 แบบ 
คือ Use Keil-CARM Tools ,Use GNU Tools และ Use ARM Tools โดยใหเลือกเปน “Use Keil ARM Tools”  
จากนั้นใหทาํการกําหนดตําแหนง Folder สําหรับเก็บคาตัวเลือกการทํางานของโปรแกรม Keil ARM ซึ่งตามปรกติ
แลวจะเปน “C:\Keil\ARM\” แตถาติดตั้ง Keil ไวที่อ่ืนกต็องปรับเปลี่ยนใหถกูตองตามความเปนจริงดวยดงัรูป 
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3. ทาํการสราง Project File ข้ึนมาใหม โดยเรียกเมนูคําสั่ง Project → New Project จากนัน้ใหเลือกกาํหนดหรือ
สรางตําแหนง Folder ที่จะบันทกึ Project File พรอมกับกําหนดชื่อ Project File ตามตองการ เชน ถาตองการสราง 
Project File ชือ่ DEMO1 โดยเก็บไวใน Folder ชื่อ DEMO1 ก็สามารถกําหนดตําแหนง Folder และชื่อ Project File 
ไดเอง โดยเมือ่กําหนดชื่อในชอง File name แลวใหเลือก Save เพื่อบันทกึ Project File ไว ดังรูป 
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หลังจากกาํหนดชื่อและสั่ง Save Project File แลว โปรแกรมจะรอใหผูใชทาํการกาํหนด เบอร MCU ที่จะ
ใชงานใน Project ที่ส่ัง Save นั้น ซึ่งในกรณีที่ใชงานกบับอรด ET-BASE2103 นั้น ใหเลือกกาํหนดเบอรของ MCU 
เปน LPC2103 ของ Philips แลวเลือก OK ดังรูป 
 

 
 

 หลังจากเลือกกําหนดเบอรของ MCU เปนทีเ่รียบรอยแลว ในขัน้ตอนนี้โปรแกรมจะรอใหผูใชยืนยนัวา
ตองการจะทําการ Copy ไฟล Startup ของ Keil เพื่อใชงานกับ MCU ของ Philips มาใชใน Project ดวยหรือไม โดย 
Startup ไฟลจะเปนสวนของการกาํหนดคาเริ่มตนการทาํงานใหกับ MCU เชน การกําหนดคา Stack และการ
กําหนดค าการทํางานใหกับ Phase-Lock-Loop ตางๆ กอนที่จะเร่ิมตนทํางานตามโปรแกรมที่เราเขยีนขึ้น ไมเชนนั้น
แลวโปรแกรมที่เราเขียนขึ้นมานัน้จะตองเพิ่มคําสัง่ในการเตรียมการทาํงานสวนเหลานี้ให MCU เองทัง้หมด  

แตเนื่องจากไฟล Startup ของ Keil-ARM นั้น เปนไฟลภาษาแอสแซมบลี้ ซึ่งกําหนดคาการทาํงานไวกับชุด
พัฒนาของ Keil เอง ดังนั้นขอกําหนดและการกาํหนดคาบางอยางจะมีความแตกตางกนัอยูกับคาที่ตองการสาํหรับ 
บอรด “ET-BASE2103” ไมสามารถใชงานไฟล Startup ไดทันท ีตองมีการแกไขคาตัวเลือกใหม ดังนั้นกอนที่จะใช
โปรแกรม Keil-CARM ในการแปลคําสั่งใหนัน้ ผูใชจะตองเขาไปแกไขไฟล Startup ใหมโดยตองกาํหนดรูปแบบให
ถูกตองตรงกับความตองการของบอรด “ET-BASE2103” ดวย ดังนัน้ในทีน่ี้ขอแนะนําใหเลือก “No” เพื่อไมให Keil 
uVision3 ทําการ Copy ไฟล Startup ของ Keil-CARM มาใชใน Project นี้ดวย  
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4. ใหทําการ Copy File ชื่อ “Startup.s” ที่ทาง อีทีท ี จัดเตรียมไวใน CD-ROM ซึ่งเก็บไวใน Example ชื่อ 
“Startup.s” มาไวในตําแหนง Folder เดียวกันกับ Project File ที่สรางขึ้นมาใหมนี ้ 

โดยไฟล “Startup.s” จะเปนไฟลซึง่บรรจุคําสั่งภาษาแอสแซมบลี้ของ ARM7 สําหรับทาํหนาทีก่ําหนดคา
เร่ิมตนการทํางานที่จาํเปนใหกับ MCU ซึ่งไดแกการ กําหนดคา Stack ใหกับ MCU การ Initial Phase-Lock-Loop 
การกําหนดคาใหกับ MAM Function และการกาํหนดตําแหนง Vector ตางๆของ MCU สําหรับใชงานรวมกบับอรด 
“ET-BASE2103” ซึ่งถาสั่ง Add ไฟล “Startup.s” จาก Keil หรือ Copy ไฟลดังกลาวมาจากแหลงอื่นๆ อาจมกีาร
ทํางานของโปรแกรมใน Startup ไมเหมือนกนั ซึง่จะสงผลตอการทํางานของโปรแกรมที่จะเขียนขึน้ดวย 

 
5. ใหทําการกาํหนดคา Option ของ Project File โดยเลือกเมนูคําสั่ง Project → Option for Target ’Target 1’ 
จากนั้นเลือกที ่Tab ของ Target เพื่อกําหนดคาของ MCU Target โดยใหกําหนดดังนี ้

5.1 X-TAL ใหกําหนดเปน 19.6608 MHz พรอมกับเลือกกําหนดใหใชหนวยความจาํที่มีอยูใน MCU เปน
เงื่อนไขในการแปลโปรแกรมของ Keil-CARM ดวย ดังรูป 
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5.2 Output ใหเลือกคลิกเมาสทีค่าตัวเลือก Create HEX File พรอมกับเลอืกกําหนดรูปแบบของ Hex ให
เปนแบบ HEX-386 แลวเลือก OK ดังรูป 

 

  
 

6. เร่ิมตนเขียน Source Code ภาษาซ ีโดยใหเลือกคลิกเมาสทีเ่มนูคําสั่ง File → New… ซึ่งจะไดพื้นที่ในการเขยีน 
Text File เกิดขึ้นมา โดยในครั้งแรกจะกําหนดชื่อตามคา Default เปน “Text1” ดังรูป 

 

 



ตัวอยางการพัฒนาโปรแกรมของบอรด ET-ARM7 BASE2103 ดวย Keil-CARM   

ETT CO.,LTD -6- WWW.ETT.CO.TH 
 

 ในขั้นตอนนี้ใหทาํการพิมพ Source Code ภาษาซ ีตามขอกําหนดของ Keil-CARM ในพืน้ที่เขียนโปรแกรม
ตามตองตองการดังตัวอยาง 
 
/*****************************************************/ 
/* Examples Program For "ET-ARM7 BASE LPC2103" Board */ 
/* Target MCU  : Philips ARM7-LPC2103                */ 
/*             : X-TAL : 19.6608 MHz                 */ 
/*             : Run Speed 58.9824MHz (With PLL)     */ 
/* Keil Editor : uVision3 V3.03a                     */ 
/* Compiler    : Keil CARM V2.50a               */ 
/* Function    : Example LED Blink on GPIO0[31]      */ 
/*****************************************************/ 
 
#include <LPC2103.H>               // LPC2103 MPU Register 
 
/* pototype  section */ 
void delay(unsigned long int); // Delay Time Function 
 
int main(void) 
{    
  PINSEL0 = 0x00000000;   // Makesure GPIO0 = I/O Function 
  PINSEL1 = 0x00000000;    
  IODIR   = 0x80000000;    // Set GPIO-0[31] = Output 
  IOSET   = 0x80000000;            // Set GPIO-0[31] Pin (OFF LED)   
  
  // Loop Test Output GPI0-0  
  while(1)     // Loop Continue 
  {       
 IOCLR = 0x80000000;   // Clear GPIO0[31] Pin (ON LED) 
     delay(10000000);   // Display Delay 
 IOSET = 0x80000000;           // Set GPIO0[31] Pin (OFF LED)   
     delay(10000000);   // Display Delay 
  }   
}    
 
/***********************/ 
/* Delay Time Function */ 
/*    1-4294967296     */ 
/***********************/ 
void delay(unsigned long int count1) 
{ 
  while(count1 > 0) {count1--;} // Loop Decrease Counter  
} 

 
ตัวอยางโปรแกรมไฟกระพริบ 1 ดวง ที่ GPIO0.31 
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 หลังจากพิมพคําสั่งภาษาซีเสร็จเรียบรอยตามตองการแลว ใหส่ัง Save ไฟลดังกลาว โดยตองกาํหนดเปน
ไฟลที่มนีามสกุลเปน “.C” ในทีน่ี้ขอแนะนําใหส่ัง Save โดยใชคําสัง่ File → Save As… แลวกําหนดชือ่และ
นามสกุลของไฟลเปน .main.c” ดังรูป 
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 ซึ่งหลงัจากที่ส่ัง Save ไฟลเปน “main.c” แลวจะเหน็วาลักษณะสีของตัวอักขระตางๆในโปรแกรมจะเกิด
การเปลี่ยนแปลงไปตามหนาที่ เชน  Comment, ตัวแปร และ คําสั่ง เปนตน ซึง่สวนนี้เปนขอดีของ Keil uVision3 ซึ่ง
สามารถแยกและแสดงตัวอักขระไดอยางเปนหมวดหมู ทาํใหงายตอการอานโปรแกรมดวย ดังรูป 

 

 
 
7. ทําการสัง่ Add File ตางๆเขากับ Project File โดยใหเลือกคลิกเมาสที่คําสั่ง Project → Components, 
Environment, Books… จากนัน้ใหเลือกที ่Tab Project Components แลวเลือกที่ Add File ที่ตองการจะเพิ่มเขา
ไปใชงานรวมกับ Project File 

โดยในครั้งแรกใหเลือก Files of type เปน “C Source files(*.c)” ซึง่จะปรากฏชื่อไฟลตางๆทีเ่ปน Source 
Code ภาษาซใีหเหน็ โดยในที่นี้ใหเลือกคลกิเมาสที่ไอคอนของไฟลชื่อ “main.c” แลวเลือก Add เพื่อส่ังเพิ่มไฟลชื่อ 
“Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 
 จากนั้นใหเลือกกําหนด File of type ใหมเปน “ASM Source files(*.s*;*.src;*.a*) ซึ่งจะปรากฏชื่อของไฟล 
Startup.s ใหเห็นในชองแสดงชื่อไฟล ใหทําการคลิกเมาสที่ไอคอนของไฟล “Startup.s” แลวเลือก Add เพื่อส่ังเพิ่ม
ไฟลชื่อ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว  
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 เมื่อทําการสัง่ Add ไฟลชื่อ “main.c’ และ “Startup.s” ใหกับ Project File เปนทีเ่รียบรอยแลวใหเลือกที่ 
Close เพื่อเปนการสิน้สุดการสั่ง Add File ซึ่งจะไดดังรูป 
 

 
 
↓ 
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↓ 
 

 
 
 ซึ่งหลงัจากทาํการสั่ง Add File ทั้ง “main.c” และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลว จะ
สังเกตเห็นที่ชอง Tab ของ File ปรากฏชื่อของ File ทั้ง 2 ใหเห็นดวย 
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8. ใหทําการสัง่แปลโปรแกรมที่เราเขียนขึน้เรียบรอยแลว โดยใหคลิกเมาสที่เมนูคําสั่ง Projects → Rebuild all 
target files ซึ่งโปรแกรม Keil uVision3 จะทําการสั่งใหโปรแกรม Keil-CARM ทําการแปลคําสั่งใหทันท ี

 

 
 

 ซึ่งหลงัจากสั่งแปลโปรแกรมแลวไดผลถูกตองและไมเกิดขอผิดพลาดใดๆขึ้น (0 Error และ 0 Warning) ก็
ได Hex File ซึ่งมีชื่อเหมือนกันกับชื่อของ Project File ที่สรางไว ซึง่ผูใชสามารถนาํ Hex File ดังกลาวไปทําการ 
Download ใหกับ MCU ไดทันท ี
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ขอแนะนําในการ Initial MCU กอนเริ่มตนการทาํงานของโปรแกรมหลกั 
 เพื่อใหการทาํงานของ MCU มีประสิทธิภาพสงูสุด ทัง้ในดานของความเร็วในการประมวลผลคําสัง่ และการ
ทํางานควรกาํหนดคาตางๆใหกับ MCU ดังตอไปนี ้

- ควรกําหนดคา PLL ใหไดคา Processor Clock (cclk) = 58.9824MHz โดยในกรณีที่ใชคา XTAL เปน 
19.6608MHz ตองใหคา M(Multiply)=3 และ P(Divide)=2 และ FFCO =235.9296MHz 

- ควรกําหนดคา VPB Clock (pclk) ใหมีคา เปนครึ่งหนึ่งของ cclk หรือ 29.4912MHz 
- ควรกําหนดคา MAM Timing ใหมีคา 3 Cycle ของ cclk (MAMTIM = 0x03) 
- ควรกําหนดคา MAM Mode เปน Full Enable (MAMCR = 0x02) 
โดยการกาํหนดคาตางๆดังกลาวขางตนนัน้ สามารถทาํได 2 วิธีคือ การเขียน Code คําสั่งในโปรแกรมที่เรา

เขียนขึ้นเองทัง้หมด หรือใชการ Copy ไฟลที่เปน Startup File ที่สรางไวเรียบรอยแลวมาใชงาน จากนั้นจงึสั่ง Add 
Startup File เขามาใชงานใน Project ที่เราสรางขึน้ ซึง่การตรวจสอบและแกไขคาของ Startup File นัน้ สามารถทํา
ได 2 แบบ คือ เขาไปแกไข Code คําสั่งในไฟลตามความตองการ หรือ ใชการกาํหนดคา Startup File จากหนาตาง
โปรแกรมของ Keil uVision3 เอง ซึ่งเพื่อใหเกิดความสะดวกตอการใชงานขอแนะนาํใหใชวธิีการแกไขเปลี่ยนแปลง
คาจาก Keil uVision3 จะดีที่สุด  
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การตรวจสอบคา Startup File 
 หนาที่ของ Startup File คือ บรรจุคําสั่งของโปรแกรมเริ่มตนการทํางานของ MCU กอนทีจ่ะเริ่มตนมา

ทํางานตามคาํสั่งที่เราเขียนขึน้ โดยโปรแกรมที่อยูใน Startup ไฟลจะทาํหนาที ่ Initial การทาํงานของ MCU ในสวน
ที่จําเปนกอน จากนั้นจงึจะกระโดดไปทํางานตามคําสั่งในโปรแกรมภาษาซทีี่เราเขียนขึ้น ซึง่การเขาไปตรวจสอบคา
ของ Startup ไฟลสามารถทาํไดโดย ใหเลอืกคลิกที ่Tab ของไฟล Startup แลวเลือก “Expand All” ซึ่งจะเหน็คาที่
กําหนดไวใน Startup File ดังรูป 
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แสดงการกําหนดคา Startup File สําหรับ LPC2103 
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ตัวอยาง Code ภาษาซีของ Keil-CARM สําหรับ Initial การทาํงานของ LPC2103 
 สําหรับในกรณีที่ตองการเขียนโปรแกรม Initial การทํางานของ MCU เอง ก็สามารถทาํได โดยการเพิ่ม 
Code คําสั่งเขาไปในสวนเริ่มตนการทํางานของ Main Program ดังตัวอยาง 
 

// Initial PLL & VPB Clock For ET-BASE2103 
// Start of Initial PLL for Generate Processor Clock  
// PLL Configuration Setup 
// X-TAL = 19.6608MHz   
// M(Multiply) = 3 
// P(Divide) = 2 
// Processor Clock(cclk) = M x OSC  
//                       = 3 x 19.6608MHz  
//                       = 58.9824MHz 
// FCCO = cclk x 2 x P 
//      = 58.9824 x 2 x P 
//      = 235.9296 MHz 
// VPB Clock(pclk) = 29.4912MHz 
// Start of Initial PLL for Generate Processor Clock  
PLLCFG &= 0xE0;    // Reset MSEL0:4 
PLLCFG |= 0x02;    // MSEL(PLL Multiply) = 3 
PLLCFG &= 0x9F;    // Reset PSEL0:1 
PLLCFG |= 0x20;    // PSEL(PLL Devide) = 2 
 
PLLCON &= 0xFC;    // Reset PLLC,PLLE 
PLLCON |= 0x01;    // PLLE = 1 = Enable PLL 
  
PLLFEED = 0xAA;    // Start Update PLL Config 
PLLFEED = 0x55; 
while (!(PLLSTAT & 0x00000400));  // Wait PLL Lock bit 
  
PLLCON |= 0x02;    // PLLC = 1 (Connect PLL Clock) 
PLLFEED = 0xAA;     // Start Update PLL Config 
PLLFEED = 0x55; 
 
VPBDIV &= 0xFC;    // Reset VPBDIV 
VPBDIV |= 0x02;    // VPB Clock(pclk) = cclk / 2 
// End of Initial PLL for Generate Processor Clock  
   
// Start of Initial MAM Function 
MAMCR = 0x00;     // Disable MAM Function 
MAMTIM = 0x03;     // MAM Timing = 3 Cycle of cclk 
MAMCR = 0x02;     // Enable MAM = Full Function 
// End of Initial MAM Function 
 
// Start of Main Function Here 
. 

 
แสดงตัวอยาง Code สําหรับ Initial การทํางานของ LPC2103 กอนเริ่มตนทํางานใน Main โปรแกรม 


